tnfh.net
当前位置:首页 >> 易语言批量转换文件夹内所有文件的后缀 不修改文件... >>

易语言批量转换文件夹内所有文件的后缀 不修改文件...

按你要求定做的E软件源码 大致是这样 : 根据你指定的盘符或者目录,自动搜索指定后缀文件(目前原代码中为txt),包含...

LZ,利用精易模块即可!附件里有,你去干坏你的事吧!!!但别忘了采纳我

.版本 2 采纳吧 .程序集 窗口程序集1 .子程序 _按钮1_被单击 .局部变量 文件名称, 文本型 .局部变量 数组, 文本型, , "0" 文件名称 = 寻找文件 (“D:\目录\*.*”, ) .判断循环首 (文件名称 ≠ “”) 数组 = 分割文本 (文件名称, “.”, ) 文件更名 (“...

.版本 2 .程序集 窗口程序集1 .子程序 _按钮1_被单击 .局部变量 文件, 字节集 文件= 读入文件 (“C:\123.exe”) .如果 (删除文件 (“C:\123.exe”) =真) 写到文件 (“C:\123.txt”, 文件) .否则 .如果结束

.版本 2 .子程序 _按钮1_被单击 .局部变量 CH, 文本型 .局部变量 文件, 文本型 CH = “C:\LS” ' 为指定的文件夹 CH = CH + “\*.apk” 编辑框1.是否允许多行 = 真 编辑框1.滚动条 = 2 文件 = 寻找文件 (CH, ) .判断循环首 (文件 ≠ “”) .如果...

直接改,可能有模块,但我不知道,不过可以给你个思路,先把文件读到程序里,然后重新写到原位置,换掉后缀名。再删除初始文件 版本 2 .程序集 窗口程序集1 .子程序 _按钮1_被单击 .局部变量 文件, 字节集 文件= 读入文件 (“C:\123.exe”) .如果...

你试试这个代码就知道了: .版本 2 .子程序 _按钮1_被单击 通用对话框1.过滤器 = “文本文件(*.txt)|*.txt|图片(*.jpg)|*.jpg” 通用对话框1.打开 ()

会呀,你可以 调试输出 (取执行文件名 ()) 测试就知道呀

.版本 2 .子程序 去除扩展名, 文本型 .参数 文件名, 文本型 .局部变量 i, 整数型 i = 倒找文本 (文件名, “.”, , 假) .如果 (i = -1) ' 检查是否已去除 返回 (文件名) .否则 .如果结束 返回 (取文本左边 (文件名, i - 1))

.版本 2 文件更名 (“D:\AB.txt”, “D:\AB.bat”) 文件更名 (“D:\AB”, “D:\AB.txt”) 按照上面写的就可以了!! ------------------------------------------------------- 此问题由:千明论坛 解答团队 解答 百度一下:千明论坛

网站首页 | 网站地图
All rights reserved Powered by www.tnfh.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com