tnfh.net
当前位置:首页 >> spring4 quArtz2 集群中的非集群怎么解决 >>

spring4 quArtz2 集群中的非集群怎么解决

配置文件呢,用个监听器去监听

spring 4.x没有配置过,这里有一个spring 3.x 的quartz定时配置,你参考参考: applicationContext

2.5版本之前所需的包: commons-logging.jar, log4j-1.2.15.jar, servlet-api.jar, spring.jar, spring-web.jar, spring-webmvc.jar 2.5版本之后所需的包: commons-logging.jar, log4j-1.2.15.jar, servlet-api.jar, spring.jar

这个问题应该是jar不兼容的问题! Spring针对quartz的支持是有严格的版本要求的 一般都是spring3.2.2配quartz2.2.1那一整套最稳定,但是Spring不同的版本的quartz,spring就不行了,里面针对spring中的JobDetailFactoryBean类不支持,详细情况需...

网站首页 | 网站地图
All rights reserved Powered by www.tnfh.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com